Libzip 版本过低或提示reinstall解决方法

发布时间:2018年4月5日 阅读:146340次 分类:PHP环境 暂无评论

编译zlib时提示 configure: error: Please reinstall the libzip distributio 或  configure: error: system libzip must be upgraded to version >= 0.11。使用Yum最新版只到0.10,不足以达到要求。


一、先删除libzip


yum remove libzip -y

SSH执行以上命令,先删除libzip  和   libzip-devel


二、下载安装并手动编译


wget https://nih.at/libzip/libzip-1.2.0.tar.gz
tar -zxvf libzip-1.2.0.tar.gz
cd libzip-1.2.0
./configure
make && make install

三、(可忽略)另外最新版本请参考官网:https://nih.at/libzip/ 1.5.0的libzip需要cmake


wget https://libzip.org/download/libzip-1.5.0.tar.gz
tar -zxvf libzip-*
cd libzip*
mkdir build && cd build && cmake .. && make && make install

如果提示cmake: command not found,需要先yum install cmake或手动编译更高版本。

标签: libzip

添加新评论 »




captcha
请输入验证码